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1 Introdution

L'aouhement est l'ation de mettre un enfant au monde. Il y a des étapes pour faire

l'aouhement. Parmi elles, la phase de la dilatation, de l'expulsion et de délivrane [1℄.

Pendant es étapes, il faut que les proédures soient bien appliquées par le personnel de la

santé, pare que toutes les proédures impliquent des risques de la vie de la mère ou partu-

riente et de la vie du bébé.

Pour ette raison, divers simulateurs numériques ont été réés a�n de donner la possibilité de

réréer les étapes de l'aouhement et de ette façon, servir omme un outil d'apprentissage

pour les étudiantes des domaines de la santé [2℄.

Le premier logiiel a été développé par l'Université de Stanford [3℄, e logiiel a été le premier

à mettre en appliation la réanimation néonatale. Après, di�érents logiiels ont été onstruits

a�n de représenter les signes vitaux [4℄, et les premiers simulateurs physiques ont été déve-

loppé par SIMA, en herhant représenter de manière omplète la réanimation néonatale

[5℄. L'entreprise Laerdal, après le développement des simulateurs d'adultes [6, 7℄ , a déidé

de travailler sur la oneption d'un simulateur de nouveau-né, apable de simuler les signes

vitaux et d'autres onditions liniques des nouveaux-nés[8℄.

En 2012, le projet SAGA (Simulateurs pour l'Apprentissage des Gestes de l'Aouhement)

a été réé. Ce projet est dédié au développement des outils pédagogiques, a�n de simuler une

ambiane omplète de l'aouhement d'un nouveau-né. Cet projet a été divisé dans trois

parties : Modèle numérique, Système Physique et une Interfae graphique. Chaune partie

aborde le projet en utilisant di�érents outils. Dans la �gure 1, vous pouvez voir l'arhiteture

du projet SAGA.

L'idée prinipale est d'utiliser e système depuis une omposante pédagogique, en permettant

de designer des senarios liniques selon le publi, les besoins et la di�ulté souhaitée. [9℄.

Dans le shéma de la �gure 1, on peut observer une relation entre haque module, 'est

pourquoi le système donne la possibilité de prendre en ompte les ations implémentées

dans d'autres parties en failitant l'apprentissage et la véri�ation de haque proédure

développée.

Dans e doument, on montrera, en premier lieu, le traitement de maillages de la tête foetale,

en utilisant des surfaes NURBS (non-uniform rational B-spline). Après, on va travailler sur

la génération des tétraèdres à partir du maillage, a�n d'inlure la tête dans la simulation

numérique. De ette manière, pouvoir simuler en tenant en ompte du volumen et de la

déformation de la tête foetale en passant pour le anal d'aouhement. Ensuite, on montrera

la mise en plae de apteurs pour déterminer les ations et les fores exerées par les mains

ou les foreps sur la tête foetale du simulateur haptique.
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Figure 1 � Arhiteture du projet SAGA [9℄.
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2 Traitement des �hiers du maillage à NURBS

Le projet SAGA, spéi�quement la partie liée au modèle numérique travaille ave des �hiers

du maillage de la tête foetale qui sont utilisés a�n de simuler l'struture physique et de

représenter divers omportements physiques. En vue de ela, nous avons besoin d'obtenir un

maillage propre et fail à utiliser. De même, l'idée est de faire une onversion à tétraèdres et

de ette manière, simuler le volumen et la déformation de la tête foetale en passant pour le

anal d'aouhement.

Pour ette raison, dans e hapitre, on va montrer di�érentes méthodes de traitement des

images en utilisant les logiiels 3DSMax et Rhinoeros et les di�ultés trouvées ave haque

méthode.

2.1 3DS Max 2015

Ii, on va montrer le proessus néessaire pour la onversion des �hiers ave les extensions

.obj et .wrl, en utilisant le logiiel 3DSMax Studio 2015. (Les �hiers .msh ne peuvent pas

s'ouvrir ave 3DSMax).

3DSMax sera utilisée ave une liene étudiante ave une validité de trois ans. De ette

manière, on pourra travailler sans souis. D'autre �te, 3DSMax est seulement disponible

sur le système d'explotation Windows.

2.1.1 Aménagement du maillage

1. Ouverture Fihier .WRL :

En premier lieu, on doit ouvrir 3DSMax. Ensuite on doit hoisir l'option Import dans

le menu qui se trouve dans la partie supérieure à gauhe, omme le montre la �gure

2 i-dessous. Immédiatement, on doit séletionner Import (Non− native �le formats

into 3ds Max ). Cette ation permet de séletionner le �hier à importer ave les ex-

tensions .obj et .wrl, entre autres options.

On a utilisé le �hier appellé foetal − head − 4466.wrl pour montrer la proédure

suivie. Nous hargeons le �hier et une fenêtre apparaît, omme le montre la �gure 3.

Il y a trois options :

� Reset sene : Cette option e�ae les sènes antérieures, a�n d'éviter le mélange

ave le �hier à importer.

� Turn to 3DS Coordinates : Si nous hoisissons ette option, on utilisera les

oordonnées natives du 3DSMax, sinon, le logiiel maintiendra les oordonnées du

�hier original.

� Create Primitives : Cet outil permet d'utiliser les fontions primitives du 3DSMax

et aussi, de prendre les textures. Sinon, 3DSMax transformera l'objet dans un
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Figure 2 � Importer des �hiers en utilisant 3dsMax 2015.

Figure 3 � Option pour importer un �hier .wrl dans le logiiel 3DSMax 2015.

maillage triangulaire.

On a laissé toutes les options séletionnées et �nalement on a hoisi OK.

3DSMax donne une fenêtre ave quatre sous-fenêtres (Figure 4) qui permettent de

travailler ave l'objet dans di�érents vues et perspetives.

2. Résolution : Nombre de polygones et triangles :

Il faut que nous observions le nombre de polygones et triangles que nous avons, a�n

d'analyser si ela est néessaire de hanger la résolution de notre objet. On peut voir

les statistiques que montre 3DS Max 2015. On hoisit le symbole + dans n'importe

quelle fenêtre. Ensuite, nous herhons l'optionXview−Show Statistis. Et on pourra
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Figure 4 � Espae de travail dans le logiiel 3DSMax 2015.

voir le numéro des polygones, triangles et vertex, omme le montre la �gure 5.

Alors, il est fondamental que nous travaillions ave moins de vertex et qu'on réduise

Figure 5 � Vue Perspetive ave le numéro de polygones, triangles et vertex.

le nombre de polygones ou triangles. Pour ette raison, on va utiliser l'outil Multires.

En premier lieu, on doit séletionner la tête et sur le �té droit, on pourra voir une

fenêtre ave le nom de l'objet et le type du format de l'image. Dans notre as, il

s'agit d'un maillage éditable. Après, dans la partie Modi�er List, il y aura une liste

déroulante, on doit herher Multires, illustrée par la �gure 6.

L'outilMultires montrera une liste des paramètres à modi�er en fontion des besoins.
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Figure 6 � Modi�ateur Multires dans 3DSMax 2015

Par rapport aux paramètres de la résolution, il montre les variables suivantes :

� Vert Perent : Correspond au nombre des vertex de l'objet modi�é par rapport

au nombre total de vertex du maillage d'origine.

� Vert Count : C'est-à-dire le numéro total de vertex de l'objet modi�é.

� Max Vertex :Permet de voir le nombre des vertex du maillage original auquel

nous appliquons Multires.

� Fae Count : Montre le nombre de faes.

� Max Fae : Indique le nombre maximal de faes.

Ces valeurs sont automatiquement mises à jour, quand nous hangeons un paramètre.

D'autre part, dans la setion de génération des paramètres, on peut trouver les options

suivantes :

� Vertex Margin : Si l'option est ativée, Multires va fusionner les vertex de tous

les objets que omposent le maillage.

� Boundary Metri : Cette option permet de mélanger les frontières des toutes

les éléments adjaents qui omposent l'objet.

� Maintain Base Verties : Cet outil permet de onserver les vertex qui sont

la base de l'objet, a�n de maintenir la struture, même quand la résolution est

diminuée. Il est très important de savoir quaprès de la diminution de la résolution,

les objets peuvent être méonnaissables.

� Multiple Vertex Normals : Il permet la génération de plusieurs normales. Elles

sont appliquées dynamiquement omme les hangements de résolution de sommet.

� Crease Angle : Il permet une variation de l'angle des normales entre 0 et 180.

Et seulement, il est aessible si l'option antérieure est ativée.

Finalement, on peut hoisir l'option Generate, a�n de générer l'objet ave les para-
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mètres que nous avons hoisi.

Pour les exemples suivants, on a séletionné quelques vertex, a�n de garantir la ré-

dution dans es zones. Dans la �gure 7, vous pouvez voir le proessus de rédution

de polygones.

Dans la �gure 8, on présente le nez et les oreilles séletionnées omme vertex base.

Figure 7 � Gauhe : tête originale ave les fontanelles et les oreilles séletionnés. Droit : tête

ave une rédution de 50 pour ent de polygones.

Après la rédution en polygones, 'est néessaire de garder les hangements faits.

En premier lieu, on doit ombiner notre objet Editable Mesh ave l'outil Multires.

Pour ette raison, on utilise l'option Collapse All (Figure 9) .

On a fait lik droit, sur Multires et on hoisit l'option Collapse All.
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(a) Tête originale ave le nez et les oreilles séle-

tionnées.

(b) Tête ave une rédution de 50 pour ent de

polygones

() Tête ave une rédution de 25 pour ent de

polygones

(d) Tête ave une rédution de 15 pour ent de

polygones

Figure 8 � Di�érentes redutions en utilisant l'outil Multires et Vertex base

Figure 9 � Menu Collapse All dans le logiiel 3DS Max 2015.
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2.1.2 Méthode 3DSMax

Le but �nal est de faire une onversion de format .obj, .wrl a .dae, a�n de pouvoir travailler

ave surfaes NURBS et de générer des tétraèdres. On va ommener en suivant les pas sui-

vants qui se montrent, en utilisant le logiiel 3DSMax [10℄, a�n d'obtenir un �hier ouvrable

dans n'importe quel logiiel Collada Editor (Utilise le format .dae).

1. Conversion Editable Mesh -> Editable Path :

On va garder le �hier en format .max (3DSMax). Ensuite, on fera un hangement

dans le type d'objet. On doit rappeler que nous sommes en train d'utiliser un format

type Editable mesh. Et pour nos besoins �naux, on doit faire une onversion au format

Editable Path.

On va séletionner Editable Mesh, on fait lik droit et après (Figure 10 ), on peut

hoisir l'option Editable Path.

Figure 10 � Conversion Editable Mesh to Editable Path dans le logiiel 3DS Max 2015.

2. Conversion Editable Path : -> NURBS

Finalement, on fait la même proédure, pour e�etuer le hangement jusqu'au format

NURBS. On va séletionner Editable Path, on fait lik droit et après, on peut hoisir

l'option NURBS, omme le montre la �gure 11. Dans la �gure 12, se montre la tête

foetale dans le format NURBS. Pour obtenir ette �gure, il faut que le nombre de

polygones soit le plus petit possible a�n d'éviter que le logiiel 3DSMax ne soit pas

apable de faire la onversion NURBS.

3. Exporter le �hier en format .dae (OPENCOLLADA)

Maintenant, on peut exporter notre tête foetale a�n d'utiliser le modèle dans un en-

vironnement haptique. Pour ette raison, nous allons exporter en utilisant le format

OPEN COLLADA .dae.

En premier lieu, on doit téléharger l'outil que se trouve dans la page o�ielle

(http://www.openollada.org/). Cet outil permettra que 3dsMax garde nos ar-

hives de manière orrete. Nous devons téléharger le �hier ColladaMaxNew.dle

http://www.opencollada.org/
http://www.opencollada.org/
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Figure 11 � Conversion Editable Path to NURBS dans le logiiel 3DS Max 2015.

Figure 12 � Tête foetale dans le format NURBS.
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(qui marhera seulement sur Windows), et on doit garder l'arhive dans le dossier

�Plugins�. La fois suivante que nous utilisions 3ds Max, l'outil ollada sera dispo-

nible.

Pour faire l'exportation du �hier, simplement on doit aller au menu prinipal et hoi-

sir l'option Exporter-(Non-native �le formats from the urrent 3ds Max Sene).(Figure

13 )

3DS Max nous montrera une fenêtre des paramètres a�n de bien exporter notre objet.

Figure 13 � Exporter des �hiers au format OPEN Collada en utilisant 3dsMax 2015.

Les paramètres se montrent dans la �gure 14.

Il s'agit des trois zones :

Figure 14 � Paramètres d'exportation OPEN Collada en utilisant 3dsMax 2015.

� Standards Options : Dans la première partie, nous trouvons quatre options :

� Bake Matries : Cet option permet la transformation de haque noeud de la

sène et de leurs animations que seront exportées omme matries.
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� Relative Paths : En utilisant ette propriété, on peut garder les images liées

aux textures en utilisant un hemin relatif, a�n d'éviter les souis.

� Copy Images : opiera tous les �hiers de texture dans le dossier � Images �

au-dessus de votre dossier de .DAE.

� Export : User de�ned properties.

� Geometry : Ii, on observe quatre options, aussi :

� Normals : Permet de faire l'exportation des normales du maillage.

� Triangulate : Permet la division du maillage en triangles.

� Inlude XRefs.

� Tangents/Binormals : Exportez les tangentes de géométrie et binormals pour

toutes les données du maillage, aussi bien que leurs indies dans la rédution

en mosaïque de maille.

� Animation : Dans ette zone, il y a la possibilité de gérer l'animation de la sène

et de faire l'exportation.

Dans la �gure 15, vous pouvez voir la tête foetale en utilisant un logiiel qui permet

de voir les �hiers ave extension .dae.

Figure 15 � A�hage tête foetale dans le format dae

2.1.3 Di�ultés dans la onversion en utilisant 3dsMax

En utilisant le logiiel 3DS Max 2015 d'Autodesk, on peut travailler de manière faile quand

on utilise des maillages polygonaux. Cependant, l'outil de onversion de maillages polygonaux

a�n d'obtenir NURBS n'est pas bon.

Ii, on montre les prinipales inonvenients :

� On doit réduire le nombre de polygones et même il y a des oasions où la tête a

perdu ses aratéristiques physiques.

� 3DS Max ne peut pas réer de NURBS à partir du maillage, par ontre, on doit faire

une onversion a Editable Path et e proessus omplique le traitement du maillage.
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� Le NURBS que génère 3DS Max n'est pas exploitable. Il génère un maillage en mo-

saïque à partir des polygones originaux. Finalement, nous avons beauoup de points

à travailler.

2.2 Rhinoeros 5.0

Ensuite, on va montrer le proessus néessaire a�n de réaliser la onversion des �hiers ave

les extensions .obj et .stl en utilisant le logiiel Rhinoeros 5.0 2015. Il y a la possibilité de

téléharger une version trial de 90 jours pour e logiiel. De même, le logiiel est disponible

sur le système d'explotation Windows et Ma.

2.2.1 Aménagement du maillage

1. Ouverture Fihier .STL

En premier lieu, on doit ouvrir Rhinoeros 5.0. Ensuite on doit hoisir l'option Import

dans le menu qui se trouve dans la partie supérieure à gauhe, omme le montre la

�gure 16 i-dessous.

Par la suite, on doit hoisir le format du �hier à importer. Rhino permet de travailler

Figure 16 � Importer des �hiers en utilisant Rhinoeros 2015.

ave les extensions .stl, .obj et .wrl, entre autres options.

On a utilisé le �hier appellé foetal − head − 4466.stl pour montrer la proédure

suivie. Nous hargeons le �hier et la fenêtre des paramètres d'importation apparait,

omme le montre la �gure 17.

Il permet de hanger les options suivantes :

� Weld Angle : Cette option permet de hoisir l'angle de soudure du maillage.
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Figure 17 � Options d'importation �hiers ave formats .stl dans le logiiel Rhino.

� Split disjoint meshes : S'il y a des problèmes dans le maillage en hoisissant

ette préférene, le logiiel détermine si les pièes disjointes d'une maille seront

automatiquement partagées sur l'importation.

� STL Model : Si le �hier .stl a des unités, Rhino permet de visualiser et hoisir

les unités appropriées.

� Always use these settings : Et �nalement, on a le hoix de sauvegarder les

on�gurations pour les importations prohaines.

On a utilisé les préférenes montrées dans la �gure 17, et Rhinoeros nous o�re

une interfae ave 4 vues possibles omme la �gure 18 illustre et selon l'aide de

Rhinoeros[11℄.

Figure 18 � Espae de travail dans le logiiel Rhinoeros 2015.

2. Résolution : Nombre de polygones et triangles
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Comme dans le as antérieur ave 3DS Max, on a beauoup de polygones et nous

avons besoin de diminuer le nombre de points a�n de travailler failement ave le

maillage. Rhino permet de onnaitre les propriétés de l'objet. Mais, on doit analyser

haque maillage, a�n de déider si 'est néessaire faire la rédution ou pas.

Pour observer les aratéristiques prinipales, on séletionne le Menu View et après

on hoisit l'option Display Options. Ensuite, la fenêtre ave les options de visibilité

sont montrées omme le montre la �gure 19 i-dessous.

L'utilisateur peut hoisir les options qu'il veut voir, dans notre as, on a séletionné

Figure 19 � Préférenes de visibilité Rhinoeros 2015

toutes les possibilités qui sont soulignées en utilisant le retangle orange de la �gure

19.

Puis, on pourra voir toutes les aratéristiques, dans le menu Properties qui se trouve

à droite dans la zone de travail de Rhino. On hoisit Details et immédiatement une

fenêtre ave les desriptions de l'objet apparait omme illustré dans la �gure 20.

Dans e tableau, on peut voir :

� Le numéro de vertex : 4596

� Le numéro de polygones : 8928

En utilisant es données, on va ommener la rédution de nombre de polygones,

triangles et vertex. En premier lieu, on va séletionner le menuMesh. Ensuite, l'option

Mesh Edit Tools -> Collapse -> Redue Vertex Count. De manière optionnel, on peut

séletionner le menu Mesh. Ensuite, l'option Mesh Edit Tools -> Redue Mesh.

Il s'agit d'un autre hemin qui permet de réduire le maillage. Après, on peut voir la

fenêtre de la �gure 21.
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Figure 20 � Propriétés du maillage dans le logiiel Rhinoeros 2015

La rédution peut être faite en hangeant le nombre de polygones, par pourentage

Figure 21 � Options de rédutions de polygones dans le logiiel Rhinoeros 2015

ou uniquement restreindre de la rédution aux polygones plans.

De même, on peut hoisir le type de rédution que l'on veut : une rédution rapide

ou une rédution préise.

Les di�érenes sont les suivantes :

� Rapide : La rédution est réalisée plus aléatoirement, ave moins de alul, e qui

permet d'être plus rapide.

� Préise : La rédution produit le moins possible d'artefats visibles. Cei implique

plus de alul et don une vitesse plus lente.

On va ommener la rédution de 8928 polygones jusqu'à 4464 polygones. De ette

façon, on obtiendra une rédution omme l'illustre la �gure 22.
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Figure 22 � Rédutions de polygones e�etués à la tête foetale sur le logiiel Rhinoeros

2015.

2.2.2 Méthode en utilisant Rhinoresurf

1. Conversion Maillage à surfaes de manière automatique :

En premier lieu, pour faire la onversion à Nurbs, 'est néessaire que nous téléhar-

gions le plugin s'appelle Rhino Resurf depuis sa page o�ielle. Il y a un trial ave

une durée de 20 jours.

Le premier pas est hoisir le maillage de la tête foetale, dans notre as. Après, nous

allons herher le Menu Rhino Resurf qui va apparaître depuis l'installation du plugin.

Du oup, on va séletionner le menu Rhino Resurf -> Automati surfaes generation

from mesh. Puis, Rhinoeros montrera la �gure 23.

De ette manière, le logiiel nous donnera la fenêtre de paramétrage pour la généra-

tion d'un réseau de ourbes et pour la surfae (Figure 23). Ensuite, il faut que nous

hoisissions l'option Curve Network et de ette façon, on va obtenir un réseau des

ourbes omme le montre la �gure 24 i-dessous.

Le pas suivant est de véri�er haque ourbe, a�n de s'assurer qu'il n'y aura auun

problème dans la génération du surfae Nurbs. Par exemple, l'idée est de trouver les

ourbes adouies pour failiter la onversion. S'il y a des problèmes, on doit utiliser

l'outil Smooth Curve. On va montrer le proessus que on a suivi pour améliorer la

ourbe de la �gure 25.

Pour orriger es erreurs, on séletionnera la ourbe qui a le problème et après on

utilisera l'option Smooth Curve du menu Automati surfae generation qui montre la

�gure 23. On va répéter le proessus ave toutes les ourbes qui ont le même problème.

S'il y a besoin de onstruire quelques lignes, on peut utiliser la ommande Polyli-

neOnmesh. Cet outil est faile d'emploi et il exige seulement une délaration du point

http://www.resurf3d.com/products.htm


2.2 Rhinoeros 5.0 18

Figure 23 � Fenêtre de génération automatique des ourbes et surfaes dans le logiiel

Rhinoeros 2015.

Figure 24 � Réseau des ourbes dans le maillage de la tête foetale dans le logiiel Rhinoeros

2015.

de début et de la �n de polyline.

Quand le réseau des ourbes est adéquat, on va réer la surfae en suivant e proessus.

Il faut que nous séletionnions le nombre de point de ontr�le (Control Point) dans

la fenêtre de la �gure 26 et après, on va séletionner l'option Create Surfae.
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Figure 25 � Problème dans une ourbe du maillage de la tête foetale dans le logiiel Rhi-

noeros 2015.

Quand, nous avons terminé la réation de la surfae, on peut hanger la visibilité des

Figure 26 � Génération automatique des surfaes dans le logiiel Rhinoeros 2015.

autres ouhes de l'objet, dans le menu Layers qui se trouve dans la partie droite de

la zone de travail de Rhinoeros. De ette façon, on peut voir de manière préise la

surfae, omme le montre la �gure 27.
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Figure 27 � A�hage des surfaes dans le logiiel Rhinoeros 2015.

De même, nous pouvons manipuler les points de ontr�le en utilisant la ommande

PointsOn, le bouton F10 ou séletionnant le Menu Edit-> Control Points -> Control

Point On et �nalement, on obtiendra les points de ontr�le de notre surfae omme

illustré la �gure 28 i-dessous.

Ave et outil, nous pouvons faire des hangements sur notre surfae failement. Pour

Figure 28 � A�hage des points de ontr�le de la surfae dans le logiiel Rhinoeros 2015.
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ne pas montrer les points de ontr�le, il su�t de taper F11.

2. Exportation du maillage à format .stl

Par la suite, on fera l'exportation du �hiers, en utilisant le format .stl . On doit

générer un maillage de polygones qui peut être exporté en utilisant le format .stl

Le premier pas est de onstruire le maillage de polygones en utilisant l'outil Polygon

Mesh. Rhinoeros va réer un maillage en prenant en ompte le Fitting Surfae, que

nous avons réé dans la setion antérieure (Figure 29). Ensuite, on va au menu File

Figure 29 � A�hage de Polygon Mesh dans le logiiel Rhinoeros 2015.

-> Export seleted. Après, on hoisit le maillage (ligne rouge dans e as) dans la zone

de travail. Rhinoeros nous montrera les fenêtres suivantes (Figure 30), es options

nous permettent d'exporter le maillage ave les paramètres dont nous avons besoin.

Figure 30 � Paramétrage de lexportation en utilisant le format .stl dans le logiiel Rhinoeros

2015.
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2.2.3 Méthode en utilisant Cage Edit

Il y a d'autres hemins pour obtenir un maillage manipulable rapidement. Il s'agit d'utiliser

le maillage original foetal − head − 4466 dans le format .stl. On peut suivre les mêmes

instrutions qu'ont été montrées dans la setion Aménagement du maillage (1.2.1).

D'abord, on séletionne le menu Transform -> Cage Editing -> Cage Edit omme illustré

dans la �gure 31. Rhino nous demande de séletionner le maillage à traiter (Selet Captive

Figure 31 � Menu Transform Rhinoeros 5.0

Objets). Après, on doit hoisir un objet pour faire le ontr�le entre les options suivantes

Boundingbox, Line, Retangle, Box. Dans la �gure 32, on observe les di�érentes options apli-

quées sur la tête foetale.
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(a) Cage Boundingbox (b) Cage Line

() Cage retangle

Figure 32 � Options Cage Edit
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Chaque option permet d'établir des paramètres de réation. Il y des ations par défaut,

mais il est possible de hanger selon les besoins. De même, on peut modi�er les options

Deformation et PreserveStruture qui nous fournissent les possibilités suivantes :

� Déformation :

� Préise : La mis à jour est lente, mais les surfaes peuvent être plus denses lorsque

les objets déformés sont optimisés.

� Rapide : Cette option génere une surfae ave moins de points de ontr�le.

� Conserver la struture :

Elle permet de onserver le maillage ou pas. Par défaut, et outil montre l'option No.

De ette façon, on peut faire des modi�ations et des déformations préises.

La struture de la tête foetale que nous avons, nous donne la possibilité de travailler ave une

age de type boîte de ontour (Bounding box ). Désormais, on montrera les paramètres que

nous avons en hoisissant ette option. En premier lieu, on �xera le système de oordonnées.

Il y a trois options :

� CPlane

� World

� 3Point

Le système de oordonnées, le plus utilisé et elui qui se trouve par défaut est Cplane.On va

séletionner e système.

Après, on doit hoisir la quantité de points et le degré de la age dans haune des trois

diretions. Rhino montre par défaut les paramètres suivants :

Cage points :

� XPointCount=4

� YPointCount=4

� ZPointCount=4

� XDegree=3

� YDegree=3

� ZDegree=3

Cependant, vous pouvez modi�er la quantité de points selon vos besoins. Dans e as, il y

a seize points de ontr�le par haque �té. Et �nalement, on doit hoisir la région que nous

voudrions modi�er. Ii, Rhino nous montrera les options suivantes :

� Global

� Loal

� Other

Les résultats �naux se montrent dans la �gure 33-a. Ensuite, on peut faire des modi�ations

en utilisant les points de la age, omment le montrent la �gure 33-b.

Quand on aura �ni les modi�ations du maillage en utilisant la age, on va suivre les indi-

ations qui ont été montrées dans la Setion 1.2.2.1 Exportation du maillage à format .stl.
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(a) Cage Boundingbox (b) Modi�ations en utilisant les points de la

age

Figure 33 � Outil Cage Edit de logiiel Rhinoeros

2.2.4 Di�ultés dans la onversion en utilisant Rhinoeros

La onversion du maillage en utilisant Rhino o�re beauoup des options a�n d'obtenir une

surfae. Cependant, il y a le risque d'obtenir des surfaes qui ont les normales inversées. Ce

problème provoque des souis dans les traitements suivants, par exemple, dans la réation

de tétraèdres. C'est toujours néessaire que nous hangions les orientations des normales

en utilisant un logiiel omme Meshlab. Nous travaillerons ave et outil dans le hapitre

suivant.
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3 Generation des tétraèdres à partir du maillage

Après de e proessus, on peut travailler ave le maillage de polygones généré a�n de

onstruire des tétraèdres.

3.1 Meshlab

Le logiiel Meshlab nous aidera ave l'aménagement du maillage après le traiement ave le

logiiel Rhinoeros. Meshlab est disponible sur les systèmes d'exploitation Windows, Linux

et Ma. [12℄

3.1.1 Aménagement du maillage

Ii, on va utiliser le �hier .stl de Rhinoeros. Nous allons faire un nettoyage du �hier . stl

en utilisant le logiiel Meshlab. L'idée est de garantir que toutes les triangles sont fermés et

qu'il n'y aura pas de surfaes ouvertes. Cette proédure nous aidera après dans la génération

des tétraèdres. Ii, on va séletionner le menu File -> Import Mesh, on herhera le �hier à

traiter et on appuiera sur Ouvrir.

Meshlab nous montrera la fenêtre suivante( Figure 34 ). Dans l'espae de travail, de manière

Figure 34 � Paramétrage pour l'importation des �hiers .stl dans le logiiel Meshlab.

immédiate, notre maillage apparaitra omme le montre la �gure 35.

Figure 35 � Tete foetale dans le logiiel Meshlab.
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3.1.2 Résolution des problèmes

Il y aura quelques fois des erreurs omme le montre la �gure 36. On peut voir qu'il y a un

soui ave la majorité des triangles. Les triangles de ouleur noire ont les normales de leurs

faes à l'intérieur et les triangles de ouleur grise ont les normales de leurs faes à l'extérieur.

Pour résoudre et inonvénient, on peut utiliser l'option de orretion des normales de

Figure 36 � Erreurs d'orientation des normales du maillage.

Meshlab. Nous la trouverons dans le menu Filters->Normals, Curvatures and Orientations

->Invert Faes Orientations (Figure 37) .

Figure 37 � Changement des orientations des normales dans le logiiel Meshlab
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3.1.3 Exportation du maillage à format .stl

D'abord, on fera une exportation en utilisant le format .stl. Mais dans e as, on va garder

sans le odage binaire. On herhe le menu File -> Export Mesh as. Et après, on suivra les

paramétrages qui se montrent dans la fenêtre suivante (�gure 38).

Figure 38 � Options pour faire l'exportation en utilisant le format .stl dans le logiiel

Meshlab.

3.2 Netgen 5.0

3.2.1 Conditionnement du maillage, format .stl :

En premier lieu, on a besoin d'autre logiiel qui nous permet de faire la onstrution de

tétraèdres. Pour ette raison, on va travailler en utilisantNetgen 5.0. Ce logiiel est disponible

sur les systèmes d'exploitation Windows, Linux et Ma. Netgen nous donne l'option d'ouvrir

des �hiers ave les suivants formats .igs, .iges , .stl, .stlb .geo et d'autres. [13℄ Quand, on

ouvrira Netgen, on ira au Menu File-> Load Geometry. Ensuite, on va hoisir le �hier

.stl.(Figure 39)

3.2.2 Résolution des problèmes

Il y aura quelques fois des erreurs omme le montre la �gure 36.
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Figure 39 � Maillage de la tête foetale dans le logiiel Netgen 5.0

Figure 40 � Maillage de la tête foetale dans le logiiel Netgen 5.0
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La géométrie, de la �gure 40, a les aratéristiques suivantes :

� Les triangles brillants ont les faes à l'extérieur.

� Les triangles opaques ont leurs faes à l'intérieur.

Le deuxième groupe provoquera des problèmes dans la génération des tétraèdres. Il faut

qu'on hange l'orientation des triangles. (Si nous ne l'avons pas fait en utilisant Meshlab).

On utilisera l'outil STL INFO de Netgen pour onnaitre l'état initial du maillage. De même,

on peut voir la sortie de la onsole de Netgen omme illustré dans la �gure 41. Clairement,

Figure 41 � STL INFO et l'info dans la onsole dans le logiiel Netgen 5.0

il y a une erreur dans notre maillage. Pour orriger les triangles, nous utiliserons l'outil

STL DOCTOR qui vient ave Netgen. On va ommener en hoisissant la possibilité de

séletionner des triangles en faisant double lik dans le menu General de STL DOCTOR.

Ensuite, on séletionnera les triangles à hanger un pour un dans l'espae du travail et puis,

on va hoisir le menu Edit Topology.

Ce menu permet de voir les inonsistanes par rapport aux triangles du maillage (option

mark inonsistent triangles) et aussi il permet de modi�er l'orientation des triangles. On

utilisera l'option Orient after seleted trig (Figure 42).

Dans la suite, Netgen nous montrera la tête foetale, omme le montre la �gure i-dessous.

De même, on peut regarder l'état du maillage, a�n de onstater que le maillage est bon

(Figure 43). On peut fermer la fenêtre de STL DOCTOR.

S'il y a d'autres souis, il y a d'autres outils de STL DOCTOR qui permettent de orriger

les normales. (Figure 44)

3.2.3 Génération des tétraèdres à partir du maillage :

Une fois qu'on aura le maillage sans auun soui. On va suivre la proédure suivante :

1. Génération du maillage :

On doit séletionner le menu Mesh-> Generate Mesh.

2. Véri�ation de qualité :

On doit hoisir dans le menu Mesh-> Mesh Quality.
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Figure 42 � STL DOCTOR dans le logiiel Netgen 5.0

3. Analyse de Géométrie :

On doit hoisir dans le menu Mesh-> Analyse Geometry.

4. Generation Surfae du maillage :

Puis, on hoisira le menu Mesh-> Mesh Surfae

5. Optimisation de Surfae :

Après, 'est néessaire de faire une optimisation de surfae en aédant depuis le menu

Mesh-> Optimize Surfae.

6. Generation Volume :

Finalement, on va onstruire le volume pour notre maillage en utilisant le Mesh->

Mesh Volume.

7. Optimisation Volume :

Pour bien �nir ave notre volume, on fera la dernière optimisation a travers duMesh->

Optimize Volume.



3.2 Netgen 5.0 32

Figure 43 � Maillage de la tête foetale après les orretions en utilisant l'outil STL DOCTOR

dans Netgen 5.0

Figure 44 � D'autres outils STL DOCTOR dans le logiiel Netgen 5.0
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Dans la �gure 45, vous pouvez voir la sortie de la onsole pour haque opération faite.

Figure 45 � Sortie de la onsole Netgen pour toute la proedure de génération des tétraèdres

3.2.4 Exporter du maillage en utilisant le format gmsh2

Après avoir suivi les pas antérieurs, on doit selétionner le format orret pour faire l'expor-

tation de notre volumen tétraédrique.

On doit herher dans le Menu File->Export �le Type->Gmsh2 Format., omme le montre

la �gure 46. Ensuite, vous pouvez hoisir l'option export Mesh de Menu File,et vous devez

selétionner un nom pour votre maillage et le proessus sera terminé. Dans la �gure 47 , on

peut voir la tête foetale après la génération des tétraèdres.
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Figure 46 � Exporter en utilisant le format gmsh2 sur Netgen

Figure 47 � Tête foetale après de la génération des tétraèdres
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3.2.5 Caratéristiques du format gmsh2

Le format .gmsh2 de notre tête foetale a les hamps suivants :

� Information générale du maillage :

$MeshFormat

2.2 0 8 -> Version - type de fihier - taille du fihier

$EndMeshFormat

� Information spéi�que selon le as (Nodes, elements, Region names, periodi relations

and post-proessing datasets)

$Nodes

5 inq noeuds dans le maillage:

1 0.0 0.0 0.0 noeud #1: oordinates (0.0, 0.0, 0.0)

2 1.0 0.0 3.0 noeud #2: oordinates (1.0, 0.0, 3.0)

3 1.0 4.0 7.0 et.

4 0.0 1.0 0.0

5 3.0 0.0 1.0

$EndNodes

$Elements

2 deux éléments

1 4 2 99 2 1 2 3 4 Numéro d'élément - type d'élément

- nombre de tags - list de noeuds

2 4 2 101 2 21 8 16 3 Elément #2: type 4 (tetraedron), physial 101,

elementary 2, nodes 21 8 16 3

$EndElements

Les éléments peuvent être de di�érents types. Par example :

� Type 1 : Noeud type ligne

� Type 2 : Noeud type triangle

� Type 3 : Noeud type quadrangle

� Type 4 : Noeud type tetradron
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4 Detetion des pressions exerées sur la tête foetale

Pour ertains aouhements, il faut que les médeins utilisent des outils d'extration ins-

trumental qui permettent de saisir la tête foetale pendant la naissane.

Il y a deux outils les plus onnus : les foreps et la ventouse.

Le foreps est onstitué par deux branhes qui sont introduites de manière séparée. Ensuite,

quand les branhes sont bien plaées, le responsable de la manoeuvre peut les attaher et les

artiuler ensemble.

Dans la �gure 48, on peut voir les pas à tenir en ompte pour la mise en plae des branhes

du foreps.

Figure 48 � Mise en plae du Foreps.[14℄

Cependant, il y a eu quelques ompliations en utilisant le foreps, par exemple les �stules

et les déhirures vaginales et l'exès de pression sur la tête foetale. Notre appliation a le but

de trouver et aluler les fores qui sont appliquées en utilisant le foreps sur la tête foetale.

4.1 Foreps

Le foreps est un outil utilisé depuis longtemps. On onsidère que l'inventeur est Monsieur

Peter Chamberlain, pare qu'il a été la première personne à utiliser le foreps en séparant les

branhes de la pine([15℄). De même, Monsieur Levret a modi�ée le foreps de Chamberlain

([16℄) et il a rée la ourbure pelvienne dans les uillères de foreps a�n de failiter l'extration

de la tête foetale et suivre le hemin pelvien. Après, Etienne Tarnier a amélioré le foreps

de Levret en ajoutant un trateur qui a permis de mettre en valeur le dernier dessin et de

ette manière, les personnels de santé peuvent suivre la trajetoire de la tête foetale. ([16℄)
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À l'époque atuelle, il y a beauoup des modèles de foreps selon le pays, de l'éole de

Médeine et les traditions de la région. Il y a plusieurs variations par rapport aux foreps.

Il y a des modèles ave les bras plus ourts que d'autres et il y a aussi d'autres modèles qui

vient ave trateur.

Dans la �gure 49, se montrent quelques modèles.

(a) Foreps Chamberlain. [17℄ (b) Foreps Levret. [18℄

() Foreps Tarnier ave trateur.[14℄ (d) Foreps Pajot. [19℄

Figure 49 � Modèles du foreps.
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4.1.1 Séletion des foreps

Dans les éoles françaises et partiulièrement à Lyon, le foreps le plus utilisé est le modèle

Levret. Cependant, e n'est pas faile de trouver e modèle sur le marhe. Pour notre appli-

ation, on a hoisi un foreps type Pajot a�n de faire des preuves ave et de �xer les apteurs

sur la surfae des haque branhe.

4.2 Capteurs de pression

Pour l'éxeution des mesures de pression et de la fore appliquée sur la tête foetale, on a

déidé d'utiliser des apteurs qui permettent obtenir une valeur de pression quand le foreps

fait ontat ave la tête de nouveau-né.

4.2.1 Séletion des apteurs

Nous avons e�etué l'état de l'art par rapport aux apteurs atuels qui nous donnent la

possibilité de mesurer ette fore. Parmi les apteurs, on peut trouver les atégories suivantes :

� Capaitives : Le fontionnement des apteurs de type apaitif est fondé dans le

hangement de la valeur de la apaitane entre deux pièes métalliques et un diéle-

trique à l'intérieur du apteur. Normalement, les tailles des apteurs sont assez petites

et pour ette raison, les prix sont élevés.

� Piézorésistives : (FSR :Fore Sensing Resistor) D'autre �té, il y a les apteurs de

type résistifs qui hangent la valeur de la résistane par rapport à la pression exerée

sur la surfae du apteur. Il y a beauoup de fournisseurs qui o�rent di�érentes options

selon la taille, la pression à mesurer, et. Dans la �gure 50,on peut observer di�érents

apteurs FSR.

Figure 50 � Capteurs Piézorésistifs : FSR.

� Matriielles : Les apteurs de type matriielle sont parfaits pour les appliations

qui ont besoin de mesurer plusiers pressions à même temps. Également, les apteurs

sont onstruits en suivant un patron, et ela peut être une ontrainte pour notre

appliation, pare que les apteurs de type matriiel ne peuvent pas être oupés ou
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modi�és. Dans la �gure 51, on trouve un exemple d'un apteur matriiel de Teksan.

Figure 51 � Capteur matriiel Teksan

Entre les options, on a hoisi les apteurs de type résistif pare qu'ils donnent les meilleures

prestations. Ils ne sont pas hers, ils sont �exibles et on peut travailler de manière intuitive

ave eux. Nous avons tenu en ompte des onsidérations suivantes :

� Le apteur doit être approprié pour notre appliation. (Caratéristiques physiques)

� Le prix

� La failité pour l'exploitation des données.

4.2.2 Caratéristiques des apteurs séletionnés

Les apteurs CP150 de fournisseurs IEE ont les aratéristiques qui se montrent dans la

table 1 :

Taille 12 m de diamètre

Gamme de pression optimale 0.007 à 7 bars

Résistane 10MWà 1kW

Pression maximum appliquée : 35 bars

Temps de montée du signal : 1à 2 ms

Table 1 � Caratéristiques prinipales du apteur CP150 IEE

On doit rappeller que la pression est la fore par unité de surfae. Il y a beauoup d'unités

de mesure, selon le hamp d'appliation. Ensuite, vous pouvez voir les plus utilisées.
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� Pasal (Pa) => 1 N / m^2

� Psi : => 6,894 X 10^3

� At : => 101325 Pa^2

� Bar : => 100.000 Pa

� mmHg : =>

� Torr :=> 133,322 Pa

Grâe aux onversions antérieures, on onnait la gamme de pression optimale du apteur en

tenant ompte du système internaional de mesure (SI) :

0.007 à 7 bars => 700 Pa (Nm/m^2) à 700000 Pa (Nm/m^2)

0.007 à 7 bars => 0.07 Nm/m^2) à 70 Nm/m^2)

4.2.3 Conditionnement des apteurs

Les apteurs que nous sommes en train d'utiliser sont de type FSR, et 'est la raison pour

laquelle on peut onsidérer que leur fontionnement sera lié au hangement d'une résistane

quand on fait pression sur la surfae ative.

C'est fondamental, alors, de onevoir un iruit qui permet de mesurer les hangements

de résistane qui varient entre 10kWet 1MW. La onsidération antérieure est fondée sur la

ourbe typique de omportement du apteur illustré dans la �gure 52.

Figure 52 � Courbe typique de omportement Capteur IEE. [20℄
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Nous avons deux options, qui se montreront ensuite :

1. Méthode Résistane Pull-down ou Pull-Up :

La première méthode pour onnaitre le hangement de résistane de notre apteur

est d'utiliser une simple résistane en on�guration Pull-down ou pull-up, omme sur

la �gure 53. L'inonvénient est que si la résistane du apteur hange entre 1kWet

(a) Con�guration de résistane Pull-down. (b) Con�guration de résistane Pull-up

Figure 53 � Con�guration des iruits de mesure en utilisant résistanes Pull-down et pull-

up

10 MW, une valeur de 10k ne sera pas omparable. De même, nous n'avons qu'une

variable à hanger, 'est-à-dire un degré de liberté. Ainsi, la oneption de iruit sera

limitée.

2. Bridge Wheatstone :

L'autre option est d'utiliser un pont de résistanes dans une on�guration Wheats-

tone. Cette option permet de mesurer la résistane du apteur FSR en ajustant les

trois autres résistanes. Dans e as, on a trois degrés de liberté pour notre onep-

tion. La on�guration Wheatstone est illustré i-dessous, sur la �gure 54.

Cette on�guration peut s'étudier en utilisant les lois de Kirhho� ou de ontempler

le iruit omme deux branhes indépendantes, omme le montre la �gure 55 et la

notion des diviseurs de tension.
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Figure 54 � Con�guration de quatre résistanes pour le pont Wheatstone

Figure 55 � Diviseurs de tension dans le pont Wheatstone
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En premier lieu, nous avons besoin de onnaitre la tension entre les bornes D et B. La

première branhe orrespond au diviseur de tension des résistanes R1 et R2. L'ex-

pression se montre dans l'équation 1.

VB1 = VCC •

R2

R1 +R2
(1)

De manière similaire, l'expression pour la branhe qui orrespond aux résistanes R3

et Rx (FSR) est a�hé ensuite.

VB2 = VCC •

Rx

Rx+R3
(2)

Après, si nous joignons les équations (1) et (2) a�n d'obtenir une expression pour la

tension VDB. Nous obtiendrons l'équation suivante.

VDB = VCC •

(

R2

R1 +R2
−

Rx

Rx+R3

)

(3)

L'equation (3) sera la fontion de transfert de notre pont de Wheatstone et on va

l'utiliser pour désigner le iruit. En premier lieu, nous avons les onditions suivantes :

� VCC = 5V

� 1KW< RX < 10MW

� Il faut que

R2

R1+R2
> Rx

Rx+R3
, a�n de garantir toujours des tensions positives.

En tenant en ompte les onsidérations antérieures, on fera le design en étudiant les

variations de haque branhe. On ommenera ave la branhe VB2. L'idée est de

trouver la meilleure résistane R3, qui donne la plage la plus large possible. Dans la

table 2, se montrent les variations par rapport à la tension dans la branhe VB2.

Selon les plages obtenues, la valeur de la résistane R3 qui permet d'obtenir meilleures

R3
Rx

Rx+R3

1kW 0.63 - 0.99

5kW 0.33 - 0.95

10kW 0.17 - 0.909

15kW 0.119 - 0.869

20kW 0.092 - 0.833

22kW 0.089 - 0.891

33kW 0.05 - 0.75

47kW 0.041 - 0.68

50kW 0.039 - 0.666

70kW 0.029 - 0.587

100kW 0.019 - 0.508

Table 2 � Planhe des variations de la fontion de la branhe deux VB2, en hangeant la

résistane R3

résultats est 10kW, pare qu'elle onède une variation entre 0.17 et 0.95. Cette plage
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garantie que la majorité des valeurs soient utilisées sans pertes dans les extrêmes

supérieures et inferieures. Le deuxième pas est faire que la fration

R2

R1+R2
soit plus

grand que le limite supérieur de la branhe deux VB2. C'est-à-dire,
R2

R1+R2
>0.909.

En utilisant les valeurs ommeriales des résistanes (Table 3), il faut que nous trou-

vions une paire adéquate.

1 1.2 1.5 1.8 2 2.2 2.7

3.3 3.9 4.7 5.6 6.8 8.2 9.1

Table 3 � Guide des valeurs ommeriales des résistanes

Après le alul, les valeurs des résistanes R1 et R2 sont 1kWet 47kWrespetivement.

On doit mésurer les valeurs réelles des résistanes qu'on va utiliser pour haun de

apteur a�n de onnaître le rapport de

R2

R1+R2
. Ensuite,dans la table 4, on montre les

valeurs mésures.

Résistane/Capteur S1 S2 S3 S4 S5 S6

R1 987W 981W 992W 990W 987W 991W

R2 45.8kW 46.3kW 46.2kW 46.3kW 46.3kW 46.3kW

R3 9.85kW 9.85kW 9.88kW 9.80kW 9.86kW 9.89kW

R2

R1+R2
0.9789 0.9792 0.9789 0.9790 0.9791 0.9790

Table 4 � Valeurs réelles des résistanes du pont Wheatstone de haque Capteur.

3. Ampli�ateur d'instrumentation ou de mesure :

Cette on�guration est utilisée a�n de traiter de petites signaux et de faire du ondi-

tionnement de signaux divers. Dans notre as, elle nous permettra de traiter et d'am-

pli�er le signal. Il y a di�érents types d'ampli�ateur qui sont montrées ensuite.

Dans la �gure 56, vous pouvez observer trois on�gurations di�érentes. La première

se montre dans la �gure 56(a), il s'agit d'un shéma qui utilise un ampli�ateur

opérationnel et quatre résistanes pour varier le gain du iruit. Cependant, e iruit

donne une impédane d'entrée basse provoant des hangements de ourant quand

nous onnetons ertains dispositifs à l'entrée.
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(a) Ampli�er ave 1 opamp. (b) Ampli�er ave 2 opamps.

() Ampli�er ave 3 opamps.

Figure 56 � Di�érentes on�gurations d'Ampliateurs d'instrumentation
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Par ontre, les �gures 56(b) et 56(), montrent des on�gurations en utilisant deux

et trois ampli�ateurs opérationnels, respetivement. Les deux iruits o�rent une

impédane d'entrée haute qui garantit que si nous onnetons un dispositif à l'entrée,

le ourant ne hangera pas trop.

Nous avons hoisi, la on�guration qui utilise trois ampli�ateurs opérationnels en

tenant ompte de deux raisons : Impédane d'entrée haute et iruit equilibré par

rapport aux signaux d'entrée [21℄.

En premier lieu, on �xera le gain en utilisant l'équation suivante :

VOut = ((Sig+)− (Sig−))×

(

R4

R2
×

(

2 •Rf

Rg
+ 1

))

(4)

Selon [?℄, on peut utiliser un paquet des résistanes R1 - R4 d'une même valeur

et �xer le gain en utilisant la résistane Rg. Dans e as, le gain de l'ampli�ateur

d'instrumentation sera déterminé selon l'équation suivante.

AI =
R4

R2
×

(

2 •Rf

Rg
+ 1

)

(5)

C'est important que nous �xions le gain en tenant ompte de la valeur de tension

d'entrée et de sortie de haque dispositif. La �gure 57 illustre le shéma général pour

le onditionnement des apteurs. On travaillera en prendre en ompte la �gure 57.

Nous onnaissons la valeur de la tension d'alimentation de iruit (5 V), et la valeur

de

R2

R1+R2
(Table 4) et la plage pour le rapport

Rx
Rx+R3

, selon les onsidérations que

nous avons montré dans la table 2.

Nous reprenons l'équation 3, et on va remplaer les valeurs omme se montre ensuite.

VDB = VCC •

(

R2

R1 +R2
moyenne−

Rx

Rx+R3
max/min

)

(6)

De ette manière, nous avons deux entrées possibles pour l'ampli�ateur :

� Le as 1 :

VDBmax = 5V • (0.9790− 0.17) = 4.045 (7)

� Le as 2 :

VDBmin = 5V • (0.9790− 0.909) = 0.35 (8)

Nous obtiendrons les valeurs montrées dans les equations (7) et (8). Alors, la sortie

peut hanger entre 4.045 et 0.35. Pour régler la plage, on va pro�ter du gain de

l'ampli�ateur de mesure. Pour ette raison, on va onsidérer un gain de 1.25 à peu

près. De ette manière, on travaillera ave une plage de valeurs par rapport à la sortie

entre 0.43 et 5. Cette plage failitera le travail ave un onvertisseur analogique-

numérique (CAN).
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(a) Disposition interne de haque blo.

(b) Shéma resumée.

Figure 57 � Shéma général pour le onditionnement des apteurs

4.2.4 Calibrage des apteurs

Les fournisseurs ont fait des essais de alibration en utilisant une barre de 4 mm ouvert

d'un aouthou de 2 mm d'épaisseur.

De notre �té, on a implémenté le système montre dans la �gure 58, on a plaé des rondelles

de la même taille que la surfae ative des apteurs. L'idée est d'utiliser di�érents poids sur
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la surfae de ontat et d'ativation de nos apteurs, dans notre as (37.21mm2
).

Pour faire le alibrage des apteurs, on a utilisé le shéma qui montre la �gure 58.

L'objetif de hanger de poids et d'établir la ourbe de omportement de haque apteur

(a) Capteur

FSR

(b) Capteur

ave une petite

rondelle

() Capteur

ave rondelle

(d) Poids

Figure 58 � Calibration des apteurs FSR

omment la �gure 52 a montré.

Après des di�érents essais, on a trouvé que la ourbe aratéristique de la fore en fontion

de la résistane de haque apteur orrespond à l'équation suivante :

Force = a ∗ resistcapb (9)

Où,

a et b sont onstantes obtenus à travers des expérienes développées et resistap est la

résistane qui donne haque apteur. Les valeurs sont présentées ii :

Force = 175544.430379465 ∗ resistcap−1.0764947921
(10)

4.2.5 Mise en plae des apteurs de pression sur le foreps

La position des apteurs sera dé�nie en prenant en ompte le bon fontionnement et la

bonne mesure de la fore et la déformation apppliquée sur la tête foetale. En premier lieu,

les apteurs sont plaés omme le montre la �gure 59.

Après, l'idée est de faire des essais, a�n d'assurer la répétitivité des expérienes et la préision

des mesures, pour ette raison, on hangera la position des apteurs en herhant le meilleur

emplaement.

On a fait des expérienes en utilisant le foreps Pajot que montre la �gure 59. On a déterminé

qu'on peut pro�ter du omportement de apteurs et de la symétrie des fores exerées sur

la tête foetale, omment la �gure 60 montre.

Du oup, on a basulé tous les apteurs dans un seul �té, 'est-à-dire, seulement une uillère

aura les apteurs et en plus, dans e as, on a utilisé le foreps modèle Levret. La �gure 61
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Figure 59 � Disposition initiale des apteurs sur le foreps

Figure 60 � Fores mesurées pour les apteurs

illustre le hangement.

Le plaement des apteurs sur un �lm plastique failite la mise en plae de apteurs sur

Figure 61 � Disposition de apteurs sur une uillère de foreps

n'importe quel modèle de foreps.
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4.3 Capteur d'éartement

Nous avons developpé une pièe a�n de �xer les uillères du foreps et aussi, ette pièe

permettra de mesurer l'ouverture du foreps. Dans la �gure 62, vous pouvez voir le design.

(a) Design de la pièe

en utilisant le logiiel

3DSMax.

(b) Impression 3D.

Figure 62 � Pièe pour �xer les uillères du foreps

De même, on utilisera un potentiomètre qui nous permettra de onnaître l'ouverture du

foreps, en utilisant la résistane. Le potentiomètre a une résistane variable entre 0 Wet 10k

W, ependant la variation sera entre 0 Wet 1.5 k W.

4.3.1 Mise en plae de apteur

Cette pièe sera �xée au milieu, dans la partie ronde, omme le montre la �gure 63 i-dessous.

D'autre �té, on va mesurer l'éartement des uillères du foreps par rapport à la résistane

donnée par le potentiomètre.

La �gure 64, montre le iruit utilisé a�n de réuperer la valeur de la résistane.

4.4 Réupération et traitement des données :

4.4.1 Caratéristiques de la Carte Arduino

Après l'étape de onditionnement, il faut que nous réupérions les données a�n d'analyser

l'information que donne haque apteur. À ette e�et, nous utiliserons une arte Arduino

UNO. Cette arte a les aratéristiques suivantes (Figure 65) :

� Alimentation : port USB ou onnexion externe.

� Tension de fontionnement : 5V
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(a) Em-

plaement

séletionné pour

la pièe.

(b) Pièe plaée

sur le foreps.

Figure 63 � Disposition de la pièe sur le foreps

� 6 entrées analogiques 10 bits

� 16 entrées/sorties numériques

4.4.2 Connexion des Capteurs de pression sur la arte Arduino

Pour notre appliation, on branhera haque sortie de nos ampli�ateurs de mesure aux

entrées analogiques que fournit Arduino Uno [22℄,omme la �gure 66 l'illustre.

Dans la �gure 66, PW est l'abréviation pour Pont de Wheatstone et AI orrespond à Am-

pli�ateur d'Instrumentation.

4.4.3 Connexion de Capteur d'éartement sur la arte Arduino

Dans le as de potentiomètre, on a utilisée aussi la on�guration de Pont Wheatstone, que

nous avons exprimée dans la setion 4.3.1. Cependant, on a ajouté une petite résistane,

a�n d'assurer que la mesure de la tension Vdb soit toujours supérieure à zero, omment la

�gure 64 montre.

On utilisera l'entrée analogique numéro 5, a�n de réuperer la valeur de la résistane, omme

l'illustre la �gure 67.
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Figure 64 � Shéma utilisée pour réuperer la valeur de la résistane

Figure 65 � Disposition des brohes dans la Carte Arduino Uno. Adaptée de [22℄
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Figure 66 � Shéma général de onnexion pour le onditionnement des apteurs et réupé-

ration des données
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Figure 67 � Shéma pour réuperer la valeur de la résistane de potentiomètre
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4.4.4 Codage sur Arduino

De même, 'est néessaire de ommander la arte Arduino UNO en utilisant l'ordinateur.

Il y a un logiiel qui s'appelle Arduino (disponible depuis sa page o�ielle : https://www.

arduino./en/Main/Software) qui permet de faire la programmation de la arte en uti-

lisant des ommandes failes. Aussi, la struture des odes dans le logiiel Arduino suivi le

shéma suivant :

//Définition des variables

void setup()

{

// ...

}

void loop()

{

// ... }

Les odes développés sur Arduino, se montrent dans la setion Annexes.

https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/Main/Software
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4.5 Interfae Graphique

Pour faire des analyses des données de manière plus faile, on a développé une interfae

graphique qui permet d'observer les hangements de apteurs de pression.

Dans e as, on a utilisé le logiiel Proessing (disponible depuis sa page o�ielle : https://

proessing.org/ que failite le développement de plusieurs appliations en 2D et 3D. Ce

logiiel est disponible sur les systèmes d'exploitation Windows, Ma et Linux.

Dans la �gure 68, on peut regarder l'interfae rée en utilisant Proessing.

Figure 68 � Interfae pour la visualisation des apteurs de pression

Nous pouvons véri�er le fontionnement de haque apteur et on a la possibilité de sauvegar-

der les donnés dans un �hier de texte. Quand on appuie sur ette option on rée un �hier

qui s'appelle sensores.txt. Ave le �hier de texte, nous pouvons gérer les données selon nos

besoins. Par exemple, on a déidé de faire l'exportation des données au logiiel Mirosoft

O�e Exel.

https://processing.org/
https://processing.org/
https://processing.org/
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5 Conlusions et travaux futurs

� En utilisant le logiiel 3DS Max 2015 d'Autodesk, on peut travailler de manière fa-

ile quand on utilise des maillages polygonaux. Cependant, l'outil de onversion de

maillages polygonaux a�n d'obtenir NURBS génère beauoup des erreurs omment

la perte des aratéristiques physiques du maillage.

� Le NURBS que génère 3DS Max n'est pas exploitable. Il génère un maillage en mo-

saïque à partir des polygones originaux. Il faut utiliser d'autre outil si nous avons

besoin de travailler ave Nurbs.

� La onversion du maillage en utilisant Rhino o�re beauoup des options a�n d'obtenir

une surfae. Cependant, il y a le risque d'obtenir des surfaes qui ont les normales in-

versées. Ce problème provoque des souis dans les traitements suivants, par exemple,

dans la réation de tétraèdres. C'est toujours néessaire que nous hangions les orien-

tations des normales.

� C'est possible d'ajouter des apteurs de pression additionnels, a�n de mesurer de

manière omplète les fores exeres par le foreps dans la tête foetale. Cependant,

il faut hoisir une arte Arduino ave plusieurs entrées analogiques ou d'autre arte

életronique plus puissante.

� Les fores qui son mesures en utilisant les apteurs de pression ont été onsidérées

symétriques dans haque uillère du foreps, a�n de failiter les expérienes et de

pouvoir mesurer dans di�érents points.

� Quand la fore de haque apteur et l'éartement ont été mesurée, on peut faire la

supposition que la somme de haun des fores sera la fore totale que la personne a

exerée en utilisant le foreps sur la tête foetale.

� C'est intéressant aussi d'obtenir les fores qui donnent les apteurs et faire une om-

paraison ave les fores que le simulateur Birthsim obtienne. A�n de réaliser ette

proédure, il faut que on tienne en ompte les déformations produites sur la tête foe-

tale. Pour ette raison, 'est néessaire si nous pouvons parler d'un travail (fore *

distane).
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6 Annexes

6.1 Annexe A. Code Arduino

/*Definiion de variables*/

int sensor1,sensor2,sensor3,sensor4,sensor5,sensor6;

//usar estas dos variables si se onetan los sensores 7 y 8

int sensor7,sensor8;

float Tension_sensor1,Tension_sensor2,Tension_sensor3,Tension_sensor4;

float Tension_sensor5,Tension_sensor6;

//usar estas dos variables si se onetan los sensores 7 y 8

float Tension_sensor7,Tension_sensor8;

int alimentaion=5000,j; //5V Valor en mV

//Puente Wheatstone Sensor 1

int R11=987;/* 1k*/

int R21=45800;/* 47k*/

int R31=9850;/* 10k*/

//Puente Wheatstone Sensor 2

int R12=981;/* 1k*/

int R22=46300;/* 47k*/

int R32=9850;/* 10k*/

//Puente Wheatstone Sensor 3

int R13=992;/* 1k*/

int R23=46200;/* 47k*/

int R33=9880;/* 10k*/

//Puente Wheatstone Sensor 4

int R14=990;/* 1k*/

int R24=46300;/* 47k*/

int R34=9800;/* 10k*/

//Puente Wheatstone Sensor 5

int R15=987;/* 1k*/

int R25=46300;/* 47k*/

int R35=9860;/* 10k*/

//Puente Wheatstone Sensor 6

int R16=991;/* 1k*/

int R26=46300;/* 47k*/

int R36=9890;/* 10k*/

//Puente Wheatstone Sensor 7

int R17=990;/* 1k*/

int R27=46300;/* 47k*/
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int R37=9850;/* 10k*/

//Puente Wheatstone Sensor 8

int R18=986;/* 1k*/

int R28=46200;/* 47k*/

int R38=9870;/* 10k*/

//Puente Wheatstone Poteniometro

int R17=995;/* 1k*/

int R27=46400;/* 47k*/

int R37=997;/* 1k*/

float A,B,C,D,E,F,V;

//Delaraión Resistenia sensores

float Res_sensor1,Res_sensor2,Res_sensor3,Res_sensor4,Res_sensor5,Res_sensor6;

float Res_pot6;

//usar estas dos variables si se onetan los sensores 7 y 8

float Res_sensor7,Res_sensor8;

float Fuerza_Tot,separaion[100℄, deformaion[100℄,Travail[100℄;

//Delaraión Fuerza sensores

double fuerza1,fuerza2,fuerza3,fuerza4,fuerza5,fuerza6,Res_pot6;

//usar estas dos variables si se onetan los sensores 7 y 8

double fuerza7,fuerza8;

//Constantes enontradas por interpolaion de la urva arateristia de los

//sensores

float ons=175544.430379465;

float ons1=-1.0764947921;

void setup(void)

{

Serial.begin(9600);

}

void loop (void)

{

sensor1 = analogRead(A0);

delay(2);

sensor2 = analogRead(A1);

delay(2);

sensor3 = analogRead(A2);

delay(2);

sensor4 = analogRead(A3);

delay(2);

sensor5 = analogRead(A4);
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delay(2);

sensor6 = analogRead(A5);

delay(2);

//usar estas dos variables si se onetan los sensores 7 y 8

//sensor7 = analogRead(A6);

//delay(2);

//sensor8 = analogRead(A7);

//delay(2);

Tension_sensor1=map(sensor1,0,1023,0,alimentaion);

Tension_sensor2=map(sensor2,0,1023,0,alimentaion);

Tension_sensor3=map(sensor3,0,1023,0,alimentaion);

Tension_sensor4=map(sensor4,0,1023,0,alimentaion);

Tension_sensor5=map(sensor5,0,1023,0,alimentaion);

Tension_sensor6=map(sensor6,0,1023,0,alimentaion);

//usar estas dos variables si se onetan los sensores 7 y 8

//Tension_sensor7=map(sensor6,0,1023,0,alimentaion);

//Tension_sensor8=map(sensor6,0,1023,0,alimentaion);

A= (Tension_sensor1/alimentaion)-(R21/(R11+R21));

B= (Tension_sensor2/alimentaion)- (R22/(R12+R22));

C= (Tension_sensor3/alimentaion)- (R23/(R13+R23));

D= (Tension_sensor4/alimentaion)- (R24/(R14+R24));

E= (Tension_sensor5/alimentaion)- (R25/(R15+R25));

F= (Tension_sensor6/alimentaion)- (R26/(R16+R26));

//usar estas dos variables si se onetan los sensores 7 y 8

//G= (Tension_sensor7/alimentaion)- (R27/(R17+R28));

//H= (Tension_sensor8/alimentaion)- (R28/(R18+R28));

V= (Tension_sensor6/alimentaion);

Res_sensor1=-(R31*A)/(1+A);

Res_sensor2=-(R32*B)/(1+B);

Res_sensor3=-(R33*C)/(1+C);

Res_sensor4=-(R34*D)/(1+D);

Res_sensor5=-(R35*E)/(1+E);

Res_sensor6=-(R36*F)/(1+F);

//usar estas dos variables si se onetan los sensores 7 y 8

//Res_sensor7=-(R37*G)/(1+G);

//Res_sensor8=-(R38*H)/(1+H);

Res_pot6=(R37*V)/(1-V);

fuerza1=ons*pow(Res_sensor1,ons1);

fuerza2=ons*pow(Res_sensor2,ons1);
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fuerza3=ons*pow(Res_sensor3,ons1);

fuerza4=ons*pow(Res_sensor4,ons1);

fuerza5=ons*pow(Res_sensor5,ons1);

fuerza6=ons*pow(Res_sensor6,ons1);

//usar estas dos variables si se onetan los sensores 7 y 8

fuerza7=ons*pow(Res_sensor7,ons1);

fuerza8=ons*pow(Res_sensor8,ons1);

// Imprimir valores de las fuerzas medidas

Serial.print(fuerza1);

Serial.print(" ");

Serial.print(fuerza2);

Serial.print(" ");

Serial.print(fuerza3);

Serial.print(" ");

Serial.print(fuerza4);

Serial.print(" ");

Serial.print(fuerza5);

Serial.print(" ");

Serial.print(fuerza6);

Serial.println(" ");

//usar estas dos variables si se onetan los sensores 7 y 8

//Serial.print(fuerza7);

//Serial.println(" ");

//Serial.print(fuerza8);

//Serial.println(" ");

delay(300);

}
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//delaraión librerias

import proessing.serial.*;

import ontrolP5.*;

//Delaraion de variables

PrintWriter datos;

Serial PuertoArduino; // Puerto serial

String inString; // Input desde Puerto serial

int lf = 10; // ASCII salto de linea

float x1 = 0;

float x2;

float y1;

float y2 = height / 2;

int xPos = 1;

PImage foto, foto1;

String[℄ lista;

float[℄ listaY = new float[10℄;

// Agregar olor si se grafian más de 6 valores

int[℄ olores = { #0000FF, #CC00AA, #00FFAA, #74DF00, #FFFF00, #FF0000, #F7FE2E};

ControlP5 p5;

void setup()

{

//Tamaño de la Ventana

size(800, 600);

p5 = new ControlP5(this);

p5.addButton("Sauvegarder donnes")

.setValue(0)

.setPosition(700,200)

.setSize(100,15)

.setColorBakground(olor(0, 0, 0))

;

// Imprime todos los puertos disponibles

printArray(Serial.list());

//Para este aso, Serial.list()[1℄, SE DEBE CAMBIAR ESTE VALOR

// POR EL PUERTO CORRESPONDIENTE

PuertoArduino = new Serial(this, Serial.list()[1℄, 9600);

PuertoArduino.bufferUntil(lf);

//rea un arhivo txt
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datos = reateWriter("sensores.txt");

bakground(0);// olor de fondo

textSize(30);// Tamaño del texto

//Cargar logos de las universidades

foto = loadImage("liris2.png");

foto1 = loadImage("unal.jpg");

}

void draw()

{

if (inString != null)

{

// Remueve los espaios en blano:

inString = trim(inString);

//Espaio para mostrar los datos

fill(255);

stroke(0);

ret(0, 0, 800, 50);

fill(255);

stroke(0);

ret(0, 50, 479, 100);

//Letura de ada sensor

fill(0, 0, 255);

text("S1", 20, 90);

fill(204, 0, 170);

text("S2", 100, 90);

fill(0, 255, 170);

text("S3", 180, 90);

fill(116, 223, 0);

text("S4", 260, 90);

fill(255, 255, 0);

text("S5", 330, 90);

fill(255, 0, 0);

text("S6", 410, 90);

fill(0, 0, 0);

text(inString, 10, 130);

fill(0, 0, 255);

text("Projet SAGA:", 20, 40);

fill(0, 0, 0);

text(" Capteurs de pression sur le foreps", 200, 40);

image(foto, 480, 51, 160, 99);
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image(foto1, 640, 51, 160, 99);

// Separa los valores reibidos usando espaio

lista = split(inString, ' ');

// Mostrar lista

printArray(lista);

// Reorre la lista de valores

for (int i=0; i < lista.length; i++)

{

// Convierte el valor en su representaion numeria ( Float )

float inByte = float(lista[i℄);

datos.print(inByte+","); // opia el dato en sensores.txt

// Reupera el valor guardado de la iteraion anterior para usarlo

//omo oordenada

y1 = listaY[i℄;

// mapeo segun tamaño de la pantalla

inByte = map(inByte, 0, 40, 0, height);

// dibujar la linea

stroke(olores[i℄);

y2 = height - inByte;

line(xPos - 5, y1, xPos, y2);

// Guarda la oordenada y atual

listaY[i℄ = y2;

// uando se aabe la linea, se vuelve al omienzo de la pantalla

if (xPos >= width)

{

xPos = 0;

bakground(0);

}

else

{

// inremento en la posiión horizontal

xPos+=1;

}

}

datos.println(" "); //

// Sinronizar el retardo on el programa que envia

//los valores al puerto serial

delay(300);

}

}
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void serialEvent(Serial p)

{

inString = p.readString();

}

publi void ontrolEvent(ControlEvent theEvent)

{//presionar botón para guardar y salir

println(theEvent.getController().getName());

datos.flush();

datos.lose();

exit();

}

void keyPressed()

{//Presionar ualquier tela para guardar y salir

datos.flush();

datos.lose();

exit();

}
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Vous pouvez trouver dans la �gure 69, la disposition des apteurs dans la arte de prototy-

page. En sahant que S1 orrespond au apteur 1, et. Ii, il y a huit apteurs pour donner

la possibilité d'obtenir plusieurs mesures. Il faut, alors, qu'on utilise une arte Arduino ave

plusieurs entrées analogiques ou d'autre arte életronique a�n de réupérer les valeurs de

haque apteur. Si vous voulez faire de nouveau les expérienes, pour vous-même, il faut que

Figure 69 � Disposition de omposants életroniques pour haque apteur sur la arte de

prototypage

vous teniez en ompte les onseils suivants :

� Suivre le shéma eletronique de la �gure 70. De même, dans la �gure 71, vous pouvez

trouver les onnexions faites pour haque apteur.

� Les onnexions doivent être véri�es, a�n de voir que le iruit fontionne de manière

orrete.

� Il y a deux soures d'alimentation :

� 5V (Sortie Arduino) : Cette tension est utilisée pour tous les iruits Pont de

Wheatstone.

� 6.3 V (Soure d'alimentation externe) : Cette tension est utilisée pour les iruits

de onditionnement (hip MCP6004)
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Pour ette raison, 'est important de ne pas mélanger l'alimentation, pare que la

oneption du iruit hangera et les valeurs de tension de sortie pour haque apteur

ne seront pas appropriées.

� C'est important que vous n'oubliez pas branher les masses. Les deux masses doivent

être branhées. A�n d'éviter des pertes dans le iruit que peuvent perturber le fon-

tionnement des apteurs.

� Vous devez respeter les valeurs des résistanes a�n de garantir le bon fontionnement

du iruit.

Figure 70 � Shéma eletronique du iruit implementé

6.4 Annexes D. Couplage Dspae Birthsim

Si vous êtes intéressée par faire la onnexion de e projet au Simulateur Birthsim. Vous

pouvez pro�ter et vous pouvez faire des onnexions diretement en utilisant les âbles VNC

qui se trouvent déjà branhés à Dspae. Il faut que vous suiviez les pas suivants :

� Vous devez branher les huit âbles aux sorties de haque apteur en suivant le ode

de ouleur qui se montre ensuite : Ou vous pouvez suivre le shéma qui se montre

dans la �gure 72.
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S1 Jaune

S2 Noir

S3 Café

S4 Violette

S5 Orange

S6 Bleu

S7 Blan

S8 Rouge

Table 5

� Vous devez branher la masse des âbles VNC à la masse de votre arte de prototypage

Arduino.
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Figure 71 � Connexion de omposants életroniques pour un apteur sur la arte de proto-

typage
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Figure 72 � Connexion de âbles depuis huit âbles de type VNC, pour haque apteur sur

la arte de prototypage
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